Installed postmastr but can't seem to use the functions

I've got some addresses I need to clean up, and I figured I would use postmastr.

I installed it, I think. I'm using remotes::install_github("slu-openGIS/postmastr", force=TRUE) and the last output i get from that is * DONE (postmastr).

But when I go to the console and try to use pm_dictionary() I get "could not find function "pm_dictionary""

I also don't see where the dictionaries would have landed in my install.

Help is appreciated.


hi @jbwhong - hm, pm_dictionary() is definitely exported (I've just double checked). Have you included library(postmastr) in your script or run that function in your console?

1 Like

Thanks @chris.prener, it appears that's what I was missing. :slight_smile:

Thanks again, @chris.prener.

Next question is - I am attempting to do the first step in the order of operations.
I am trying to use pm_identify and inside the first parentheses I am putting "../reference/pm_identify.html" like, literally typing two periods.

Like this:

obtb <- pm_identify (../reference/pm_identify.html) (obtb, var = "DELADDR")

The error message I am getting is Error in varQN %in% names(.data) : object '..' not found

I am guessing I am supposed to replace the two dots with something else?

Did you forget quotes?

@HanOostdijk Unless I am missing something, I don't see quotes in the first parens in the example for pm_identify given in the order of operations.

In that example the sushi1 tibble is used that is already available in the workspace ( maybe provided by the package). In that case you specify the name of the object without quotes.
I think in this case you try to read a file (?).
If the pm_identify allows a file to be used as first argument, you have to specify it with quotes.
If it doesn't allow a file you should read in a separate step the file (specifying quotes) into a tibble and specify the tibble object (without quotes) in a pm_identify step.

@HanOostdijk I am getting around it by ignoring the first parens. the first parens appear to be the URL, relative to the order of operations page, to find the reference for the given function. When I go to the reference, I don't see two sets of parens for the function.

If you solved your problem, please indicate it as solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.