Installing OpenCL package

I am trying instal OpenCL package, but getting message:

ERROR: OCL not set!

You will need a working OpenCL SDK with headers
and libraries for both i386 and x64

Set OCL to the root of the SDK

You can also set individial variables OCLINC,
OCL32LIB and OCL64LIB. If they are not set,
the default layout will be assumed.

ERROR: configuration failed for package 'OpenCL'
* removing 'C:/Users/.../AppData/Local/R/win-library/4.2/OpenCL'

How I can fix it?
I have latest NVidia drivers

Nvidia drivers do not include OpenCL by default, make sure you are enabling OpenCL when installing your GPU drivers.

There is no such option during driver installation.
I have Nvidia GPU. What else I need install?

I tried install some CUDA 11 toolkit (that eat 6 GB on drive C:) from Nvidia, but still getting same message when installing OpenCL package in R.
Also I tried (in CMD) set OCL=dir to .h files, still same result

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.