installing package DESCRIPTION failed for package 'GenomeInfoDbData'

hi everyone,
i tried to install GenomeInfoDbData for bioinformatics project, by using this chunk of code:

if (!requireNamespace("BiocManager", quietly = TRUE))

This is what i Get:

Bioconductor version 3.11 (BiocManager 1.30.10), R 4.0.1 (2020-06-06)
Installing package(s) 'GenomeInfoDbData'
installing the source package ‘GenomeInfoDbData’

trying URL ''
Content type 'application/x-gzip' length 10413139 bytes (9.9 MB)
downloaded 9.9 MB

  • installing source package 'GenomeInfoDbData' ...
    ** using staged installation
    Error in .read_description(dfile) :
    file 'C:/Users/àøéàì ñéîåï/AppData/Local/Temp/Rtmp845wZr/R.INSTALL12d077b32b23/GenomeInfoDbData/DESCRIPTION' does not exist
    ERROR: installing package DESCRIPTION failed for package 'GenomeInfoDbData'
  • removing 'C:/Program Files/R/R-4.0.1/library/GenomeInfoDbData'

The downloaded source packages are in
‘C:\Users\àøéàì ñéîåï\AppData\Local\Temp\RtmpmY6T3T\downloaded_packages’
Warning message:
In install.packages(...) :
installation of package ‘GenomeInfoDbData’ had non-zero exit status

Can someone help me please?

You seem to have non-ASCII characters in your windows user name, R has problems with that, try installing into the system level package library instead.

You can change the defaul library by setting your R_LIBS_SITE environmental variable on a .Reviron or .Rprofile file e. g.

# In .Renviron file you can set it by adding this line
R_LIBS_SITE="C:\\Program Files\\R\\R-4.0.1\\library"

Solved, thank you so much!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.