Installing PKI package

Hello,

I have developed an R Shiny dashboard with flexdashboard. So, the file type is a .Rmd. I was trying to publish it to shinyapps.io by clicking on the "Publich" button, but unsuccessfully, is it requires the PKI package. It suggests me to install it, I accept, it tries to install but doesn't do anything else afterwards. Then, I try to install manually but the following messages are returned:


I have made a lot of research on how to download and properly install PKI but haven't been lucky. Do you know how to solve this issue?

Much appreciated!