Installing RMarkdown 1.2 and above


#1

Hi All,

I have newly installed RStudio version 3.3.2 on my system and is trying to use RMarkdown in R, but I keep having the message below;
image

I have installed MiKTeX 2.9.6361 on my system before opening the RMarkdown project.
I see that there is rmarkdown 1.6 version, so I deleted the version 1.1 on my system and re-installed it again, but each time it’s the version 1.1 that keep instaling. My CRAN mirror is set to “Global (CDN) - RStudio”.

Can anyone point me in the right direction on how to resolve this problem, please?

Many thanks.


#2

Do you mean R version 3.3.2? Rstudio just recently (this week) released version 1.1.383, so it is more likely that you have R 3.3.2 installed. With that being said, the current release of R is 3.4.2 and the current version of RMarkdown available on CRAN is 1.6. It is possible that the version of R you are using is causing the problem with downloading the new version of Rmarkdown. I would recommend downloading the newest version of R and then trying, which can be found here


#3

Hi Tyler,

Thanks a lot for your prompt response. You are correct that it’s my R version that is 3.3.2. I had RStudio version 1.0.143. I did uninstall both R and RStudio on from my device and reinstalled the current version of both and also reinstalled MikTex. I had the problem of Rcpp package not updating (initially) after the reinstalling process, but that has been fixed also after several trials. It was a case of the Rcpp package being stored in the wrong directory.
Everything I need for my current project is all working okay now.

Many thanks for your help and best regards. Have a lovely weekend.