Installing Rstudio : error while loading shared libraries:

I just installed Rstudio through rstudio-2022.02.3-492-amd64.deb on Linux Mint 20.3 and get

rstudio: error while loading shared libraries: cannot open shared object file: No such file or directory



Welcome to the RStudio community!

Maybe this post might help. It's not talking about RStudio, but I think the error message has to do with some Linux path issues rather than RStudio itself.

Hope this helps,

I had the same error, and Rstudio couldn't start. I'm running the Ubuntu 20.04 LTS, and the problem was downloading the wrong Rstudio distribution (Ubuntu 22). I downloaded the Rstudio for Ubuntu 18+ version, and the problem disappeared. I hope it was helpful.


Your suggestion @sharifrahmani_e solved the issue. Many thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.