Intstalling GDAL >= 2.0 on Redhat

I am trying to use the tmap package with RSP on a Redhat server. tmap depends on GDAL >=2.0 and apparently GDAL 2.0 is not available in any official package repositories. We could build it from source but IS discourages that. Is there a repository others have used to install GDAL >= 2.0?

We had the same problem at work but we built it from source specifically for our R environment. This is working well for us.

2 Likes

here is some materials that you need

https://trac.osgeo.org/gdal/wiki/DownloadSource


./configure

make

make install


echo "your_gdal lib"  /etc/[ld.so](http://ld.so/).conf.d/libgdal-x86_64.conf
# echo "/usr/local/lib" /etc/[ld.so](http://ld.so/).conf.d/libgdal-x86_64.conf

1 Like

I can run ./configure but when I run make I get the following error:

fatal error: gdal_version.h: No such file or directory

Been looking online a lot but have not found a solution.

I did find the file here though: https://cran.r-project.org/bin/windows/extsoft/3.5/include/gdal_version.h

I am trying an earlier version (2.2 instead of 2.4) and it seems to be working.