Issue in blogdown package

Hi all,

I am not able to create a simple website through blogdown package and also May I know ho do I deploy/publish this to R server? I have followed below steps

Step 1

Step 2

Step 3

Step 4 : when I run below code, I get error not sure why


Error message

createTcpServer: address already in use
Error in as.vector(x, "character") : 
  cannot coerce type 'environment' to vector of type 'character'

Also May I know how do I publish this website to R server?


The error you get may happen if you already have a site served. Can you try again to run serve_site in a cleaned and new R session ?

About deployment ? What does a R server mean ?
Blogdown render a static website that be deployed to any web server.
You have some solutions describe in the book

1 Like

Hi ,

Thanks. Deployment means can I publish this to the server? Like we do for R shiny applications. I need to share this website to my colleague so. Can i have the link here?

Also may I know what you meant by " already have a site served" ?

I tried again. Still getting same error

This is very ambiguous, whose server? If you mean to publish to, then the answer is no, you can't. If you mean to publish to your own server, then you just have to install a web server and copy the files to the proper folder, read the chapter cderv pointed out to learn what are your options.

1 Like

Thanks...............But regarding the error, still I am getting. I started a new session as well.

Which version of blogdown to you have ?

Hi, It is 0.61.0. Below is for your reference

> blogdown::hugo_version()
[1] ‘0.61.0’

Thanks for your hugo version.
An your blogdown :package: version ? packageVersion("blogdown")?

Hi Its

> packageVersion("blogdown")
[1] ‘0.10’

Lastest version is 0.17

Can you update and see if this fixes your error?

1 Like

Thanks. Will check and let you know

Nope. It is not working. I followed below steps to update the package

  1. Downloaded blogdown_0.17.tar.gz as shown below

  1. Installed it in R as shown below


But getting below error

Also I am getting this below error

Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) : 
  namespace ‘xfun’ 0.7 is being loaded, but >= 0.10 is required

The package dependencies need to be updated as well. Why are you doing the update manually by downloading the tarball instead of using a CRAN mirror?

install.packages("blogdown", repos="")

Thanks will check this

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.