Issue with RStudio

I have been working on RStudio for a few weeks but suddenly it has started giving me this error everytime I try to open a new R Markdown. Neither does the code run and display any results. I have gone through several threads but not able to resolve this. I have even installed & updated the packages mentioned but to no avail.

Somebody please help.

What error? Need more info.

What version of R do you have? The packages listed as available are rather old.

I uninstalled & downloaded the latest version, updated the packages too but same issue occurs. Unless where the packages are installed could also give issues.

Can you share

  • sessionInfo()
  • Have you already some installed packages ? (check Packages pane or installed.packages())
  • Have you a CRAN repo configured ? (getOption("repos"))
  • Are you being able to install packages ? like install.packages("glue")

Thanks for sharing this in order for us to know more.

I opened my laptop after 4 days and there is no error anymore. I dont know what to make of it.

1 Like

This could have been an issue with packages still loaded while new versions installed. Anyway, glad it works now !

1 Like

Try update.packages()

Just attached the screenshot. Sorry it wasn't uploaded before.

And can you copy and paste the text of the error message? It will help us be able to read it and others who may face the same problem will be able to find this discussion as well.

Everytime I click on new file & then on R Markdown, it lists package versions required.
evaluate 0.13 is required but 0.10 is available.
glue 1.3.0 is not available
htmltools 0.3.6 is required but 0.3.5 is available.
knitr 1.22 is required but 1.14 is available.
rmarkdown 1.12 is required but 1.1 is available.
stringr 1.2.0 is required but 1.1.0 is available.
tinytex 0.16 is not available.
xfun 0.3 is not available.

1 Like

I did, still facing the issue.