Keyboard stuck in R Studio

Hello, my RStudio has been giving me issues from my keyboard. Whatever I type it will keep the first letter I type be what is shown. For example, If I want to type "hello" it will appear at "hhhhh". This will reset to a different letter approximately after 2 minutes. I have uninstalled base R and R studio, restarted my own computer and nothing has helped. My keyboard is fine everywhere else I type, including in base R. I saw a couple of people have this same question but there were no solutions. As regard to update it says I have the latest version of R studio.

The last thing I remember seeing/happening was when I was typing I saw something appear at the top of my script as "Unicode On" or something similar. I looked up what to do with that and did File > Reopen with Encoding > and have ISO 8859-1 (System Default) on.

In general, whenever reporting issues like this you should include your operating system, and the versions of R and R studio you are running.

Also, some additional debugging advice. Try to isolate the problem as much as possible.

It happens in R Studio, great... Where in R Studio? Check:

  1. Console
  2. Terminal
  3. Source Editor
  4. Searching the Help tab
  5. If you make a New Project, in the text box where it asks for a Directory Name, does it happen there too?
  6. Is it all the keys or just some of them? Test, if not all of them, several.
  7. You tried rebooting, what about another user account? Create a new user, log out and log in with the new account and try again.

I have absolutely zero idea why you would get repeated keys only in R Studio, but all of these things might help someone who would have an idea know what the right answer for you is.

Last thing I am going to suggest because I just learned about it yesterday and it appears to solve all the things R Studio IDE related.
From @andresrcs

Hello! Sorry just created an account solely for this issue since I have been trying to trouble shoot it for quite a bit.
So this issue is in the console, terminal and source editor (everywhere in R Studio).. Just tried the New Project and it is also having the issue there too.
All the keys does this. If I leave it idle for a little over a minute, it will be stuck on whatever next key I type.
I also cleaned out my AppData belonging to RStudio and reinstalled it to no avail.
I am using a Windows 10 and running Version 1.3.1073 for R Studio

Also - I did the Rendering Engine and no luck

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.