Knitr not working

Being using Rstudio for a while now, but after buying a new computer and installing Rstudio and all the packages knitr is not working.

After clicking in knitr nothing happens, regardless of whether the output is pdf, html or word. The command window stays blank, no error message appears, neither any other information.

Knitr package is installed as it is MikTex.


Without much information I don't think anyone will be able to help. Please provide more context and information. There is no reason that this is doing nothing. If it does, this should be specific to your system and it will be difficult to help like this.

Please try again restarting the computer and checking the installation.

Thanks !

If you search through the postings here you will find this is not so unusual. Various suggestions that have worked for some people include removing and reinstalling various packages. In my case, xfun was the issue.

1 Like


Thanks for both replies.
The problem solved itself after reinstalling both r and rstudio.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.