Launch multiple RStudio sessions from Docker

I managed to install RStudio through Docker, running on port 8787.
I wanted to add another RStudio session (not necessarily sharing the same volumes), so I tried the following:

sudo docker run -d -p 8788:8787 -e PASSWORD=mypassword rocker/rstudio:3.2.0

Which seems to work since it does not throw any error and when I do docker ps I see this:

CONTAINER ID        IMAGE                                 COMMAND                  CREATED             STATUS              PORTS                        NAMES
cb724b319ebb        rocker/rstudio:3.2.0                  "/init"                  5 minutes ago       Up 5 minutes        0.0.0.0:8788->8787/tcp 

BUT when I go to http://XX.XX.XXX.XX:8788/ there is no RStudio session appearing (http://XX.XX.XXX.XX being the elastic ip adress of my ec2-server).
I made sure I added 8788 port authorized in the security group.

Do you know what I am missing?

Have you tried

sudo docker run -e PASSWORD=yourpassword -p 8788:8787 rocker/rstudio:3.2.0

Just tried, this is what I get:


[fix-attrs.d] applying owners & permissions fixes...
[fix-attrs.d] 00-runscripts: applying...
[fix-attrs.d] 00-runscripts: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] add: executing...
Nothing additional to add
[cont-init.d] add: exited 0.
[cont-init.d] userconf: executing...
[cont-init.d] userconf: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.