Lavaan installation: Error in library.dynam(lib, package, package.lib) : shared object ‘tmvnsim.dylib’ not found

Hi together,

i am currently wokring with R Studio (conda install, Mac OS 10.15.7) to perform a statistical analysis. Because of that , i need the lavaan package. I have tried to install it, and the following occured. I have the "non-zero exit status" message occasionally whe installing packages, then i download the package from the cran website which works out well. Now, what is new and unique is the part with the "shared object ‘tmvnsim.dylib’ not found". I have no idea why this message popped up, and i haven't found a solution in this forum or otherwise. Can somebody help me with this issue? Thanks in advance.

RStudio through Anaconda is not officially supported, and installing packages directly from CRAN in a conda environment is not straightforward (I have never managed to make it work seamlessly) so if you really need to work with Anaconda is better to install packages with the Anaconda Navigator or from the system terminal with the conda install command. Although, if you are not going to make heavy use of Python in your project I would strongly recommend using a stand alone installation of R and RStudio.

Thanks for your fast reply. That explains a lot of my problems. I tried the conda install command and I could install lavaan successfully.