Library(tidyverse) does not work

Hi,

I am trying to install Tidyverse and I encounter the following problem

library(tidyverse)
Registered S3 methods overwritten by 'broom':
method from
augment.rowwise_df
augment.tbl_df
glance.rowwise_df
glance.tbl_df
tidy.rowwise_df
tidy.tbl_df
Error: package or namespace load failed for ‘tidyverse’:
.onLoad failed in loadNamespace() for 'broom', details:
call: loadNamespace(name)
error: there is no package called ‘backports’

When I try to install the package backports, it get the following
Warning in install.packages :
installation of package ‘backports’ had non-zero exit status

What should I do ?
I have installed R and Rstudio 10 days ago. I have the version Version 1.2.5033

Thanks in advance,

Christine

It means there is an issue with the backports :package: installation.
Is it installed already ? Do you see it in the package pane in RStudio ?

In a clean R session (maybe outside Rstudio in R GUI?), try to reinstalling backports

Can you show the whole message you get when you try to install this package? You are omitting the useful parts

1 Like

Here is what I get / Thanks for your help

install.packages("backports")

There is a binary version available but the source version is
later:
binary source needs_compilation
backports 1.1.5 1.1.6 TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel) y
installing the source package ‘backports’

trying URL 'https://cran.rstudio.com/src/contrib/backports_1.1.6.tar.gz'
Content type 'application/x-gzip' length 16703 bytes (16 KB)

downloaded 16 KB

  • installing source package ‘backports’ ...
    ** package ‘backports’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    ERROR: compilation failed for package ‘backports’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/backports’
    Warning in install.packages :
    installation of package ‘backports’ had non-zero exit status

The downloaded source packages are in
‘/private/var/folders/6g/_x6c2bw9195068cskbrhlns00000gn/T/Rtmpm6j35j/downloaded_packages’

The easiest solution would be to answer "no" when asked to install from source, that way you would get a precompiled binary that is much easier to install but a little older.
If you need the latest version then you have to install it from source, for that you need to have
xcode installed in your system

xcode-select --install

And the recommended development tools for MacOS systems
https://cran.r-project.org/bin/macosx/tools/

1 Like

Thanks a lot. It worked.

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.