Libssl 1.0.0 outdated dependency

rstudioserver

#1

Morning all!

I've installed rstudio-server on Debian 9.0, and get errors on startup that it is looking for libssl.so.1.0.0. I have installed libssl 1.0.2, as that is what is in my repos. I don't want to downgrade a SSL package that was updated for security patches.

Can the team update the dependency, or am I left with installing what is now considered an insecure library?


#2

What version of RStudio server are you installing?

Debian 9 has a newer version of OpenSSL than most Linux distributions, and we have a special RStudio Server package that is compiled against Debian 9's OpenSSL. You can get this package from here:

https://download2.rstudio.org/rstudio-server-stretch-1.1.447-amd64.deb


#3

Hi, I followed the instructions on the site and installed rstudio-server-1.1.447-amd64.deb. I tried looking for debian-specific instructions, and did some googling for the fix. Looks like a successful install, thanks.

Do I need to do anything to show this topic as solved or closed or anything? This is my first post on this message board. (It looks like a Disqus instance, so probably not.)


#4

Glad it's been resolved! You can mark the solution with the little check box next to the answer (it's tough to describe, so I made up a little pictorial that's at the link, below).

Thanks