Mlflow not running on machine

Hello,
Please I installed the Mlflow package, and want to learn to begin using it in my machine learning projects. However, after loading the library in R Studio and I run this line of code mlflow_log_param("foo",42) I get the error message below in my console:

Error in rethrow_call(c_processx_exec, command, c(command, args), pty,  : 
  Command 'C:/Users/IFEANYI/AppData/Local/r-miniconda/envs/r-mlflow-1.19.0/mlflow' not found @win/processx.c:982 (processx_exec)

I get the same error message when I run mlflow_ui() too. Do I need to install and load the processx library in order for mlflow to run on my Windows10 machine?
Please your helpful advice would be greatly appreciated. Thanks

Hi guys,
After loading the Mlflow library in R Studio on my windows 10 machine, and I run the code install_mlflow(python_version = "3.6") I get the following message printed in my console, which seems to indicate that all requirements are satisfied:

Requirement already satisfied: mlflow==1.19.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (1.19.0)
Requirement already satisfied: pandas in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.1.5)
Requirement already satisfied: pytz in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (2021.1)
Requirement already satisfied: packaging in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (21.0)
Requirement already satisfied: requests>=2.17.3 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (2.26.0)
Requirement already satisfied: alembic<=1.4.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.4.1)
Requirement already satisfied: entrypoints in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (0.3)
Requirement already satisfied: Flask in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (2.0.1)
Requirement already satisfied: docker>=4.0.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (5.0.0)
Requirement already satisfied: pyyaml>=5.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (5.4.1)
Requirement already satisfied: numpy in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.19.5)
Requirement already satisfied: click>=7.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (8.0.1)
Requirement already satisfied: querystring-parser in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.2.4)
Requirement already satisfied: prometheus-flask-exporter in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (0.18.2)
Requirement already satisfied: protobuf>=3.7.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (3.17.3)
Requirement already satisfied: sqlparse>=0.3.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (0.4.1)
Requirement already satisfied: sqlalchemy in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.4.23)
Requirement already satisfied: gitpython>=2.1.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (3.1.18)
Requirement already satisfied: waitress in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (2.0.0)
Requirement already satisfied: databricks-cli>=0.8.7 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (0.15.0)
Requirement already satisfied: cloudpickle in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from mlflow==1.19.0) (1.6.0)
Requirement already satisfied: python-editor>=0.3 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from alembic<=1.4.1->mlflow==1.19.0) (1.0.4)
Requirement already satisfied: Mako in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from alembic<=1.4.1->mlflow==1.19.0) (1.1.5)
Requirement already satisfied: python-dateutil in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from alembic<=1.4.1->mlflow==1.19.0) (2.8.2)
Requirement already satisfied: importlib-metadata in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from click>=7.0->mlflow==1.19.0) (4.8.1)
Requirement already satisfied: colorama in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from click>=7.0->mlflow==1.19.0) (0.4.4)
Requirement already satisfied: tabulate>=0.7.7 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from databricks-cli>=0.8.7->mlflow==1.19.0) (0.8.9)
Requirement already satisfied: six>=1.10.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from databricks-cli>=0.8.7->mlflow==1.19.0) (1.16.0)
Requirement already satisfied: websocket-client>=0.32.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from docker>=4.0.0->mlflow==1.19.0) (1.2.1)
Requirement already satisfied: pywin32==227 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from docker>=4.0.0->mlflow==1.19.0) (227)
Requirement already satisfied: gitdb<5,>=4.0.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from gitpython>=2.1.0->mlflow==1.19.0) (4.0.7)
Requirement already satisfied: typing-extensions>=3.7.4.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from gitpython>=2.1.0->mlflow==1.19.0) (3.10.0.1)
Requirement already satisfied: smmap<5,>=3.0.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from gitdb<5,>=4.0.1->gitpython>=2.1.0->mlflow==1.19.0) (4.0.0)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from requests>=2.17.3->mlflow==1.19.0) (1.26.6)
Requirement already satisfied: idna<4,>=2.5 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from requests>=2.17.3->mlflow==1.19.0) (3.2)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from requests>=2.17.3->mlflow==1.19.0) (2021.5.30)
Requirement already satisfied: charset-normalizer~=2.0.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from requests>=2.17.3->mlflow==1.19.0) (2.0.4)
Requirement already satisfied: greenlet!=0.4.17 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from sqlalchemy->mlflow==1.19.0) (1.1.1)
Requirement already satisfied: Werkzeug>=2.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from Flask->mlflow==1.19.0) (2.0.1)
Requirement already satisfied: itsdangerous>=2.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from Flask->mlflow==1.19.0) (2.0.1)
Requirement already satisfied: Jinja2>=3.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from Flask->mlflow==1.19.0) (3.0.1)
Requirement already satisfied: MarkupSafe>=2.0 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from Jinja2>=3.0->Flask->mlflow==1.19.0) (2.0.1)
Requirement already satisfied: dataclasses in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from Werkzeug>=2.0->Flask->mlflow==1.19.0) (0.8)
Requirement already satisfied: zipp>=0.5 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from importlib-metadata->click>=7.0->mlflow==1.19.0) (3.5.0)
Requirement already satisfied: pyparsing>=2.0.2 in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from packaging->mlflow==1.19.0) (2.4.7)
Requirement already satisfied: prometheus-client in c:\users\ifeanyi\appdata\local\r-mini~1\envs\r-mlfl~1.0\lib\site-packages (from prometheus-flask-exporter->mlflow==1.19.0) (0.11.0)
[1] "mlflow==1.19.0"

Nevertheless, when I go ahead and run an API call, such as mlflow_ui(), I still get this error message printed in my console:

Error in rethrow_call(c_processx_exec, command, c(command, args), pty,  : 
  Command 'C:/Users/IFEANYI/AppData/Local/r-miniconda/envs/r-mlflow-1.19.0/mlflow' not found @win/processx.c:982 (processx_exec)

I have anaconda installed on my PC, which I believe should take care of conda installation. I sincerely do not know where to go from here, please guys.