My new R is not found for my Ubuntu installation

Hi there,

I am hoping someone can help me. I have tried to remove a previous installation of R from this Ubuntu system (20.04) as I want to upgrade to a newer version of R.

As you can see on the terminal text R is not found but when I proceed with sudo apt install r-base-core it already tells me that the newest version is installed. R is never getting found by the OS. I have tried to wipe some directories but still not winning.

Any help?

computerxx:~$ R --version

Command 'R' not found, but can be installed with:

sudo apt install r-base-core

computerxx:~$ sudo apt install r-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
r-base is already the newest version (4.2.1-1.2004.0).
The following packages were automatically installed and are no longer required:
  linux-headers-5.13.0-51-generic linux-hwe-5.13-headers-5.13.0-51 linux-image-5.13.0-51-generic linux-modules-5.13.0-51-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Weird. What happens if you load R in a terminal and issue the command



Can't do that. R is not available. I can't invoke it.

Well I am no expert but you might want to try removing R and reinstalling it.

sudo apt-get remove r-base-core

supposedly will work.

IIRC you have R files/directories in
1] "/home/john/R/x86_64-pc-linux-gnu-library/4.2"
[2] "/usr/local/lib/R/site-library"
[3] "/usr/lib/R/site-library"
[4] "/usr/lib/R/library"

where john is my computer name. You may have to hunt down and kill them manually.

Most recent thing I could find on this is from Complete remove and reinstall R

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.