Nested project hell usethis::create_package()

Error Information:

I get this error message whenever I try to use the create_package() command from usethis. This error appears regardless of what folder I'm in.

New project 'myfancything' is nested inside an existing project '.'. This is rarely a good idea. Do you wish to create anyway?
1: Negative
2: No
3: Absolutely

Description of issue -
I'm trying to use the create_package() command, but I get an error message about a nested project. The only issue is that as far as I can tell I do not have any Projects in this directory. This issue also occurs when I try to use the command in any other folder as well.

Is this an error I can ignore? Or are there other ways to check if I have a project in this directory?

Steps taken so far -

  1. I tried looking for any files with the extension .Rproj in my working directory but couldn't find any.
  2. reinstalled devtools, usethis and/or using development versions

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.2.1237
  • OS Version: Mac OS 10.14.3
  • R Version: 3.5.1
1 Like

I've had this happen when I had a Project in some higher level folder. Is the directory where you're creating the project nested inside a higher level folder or series of folders, one (or more) of which is the top-level folder of an R Project (i.e., the folder with the rproj file for that project)?

@joels, that was my original thought, but I've tried resetting my working directory to my home directory for my computer and as far as I can see there are no project files at a higher level. I've been looking by searching for files with the extension for .Rproj in finder.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.