nFactors-Installation package error message in R

Hi all,
I try to run nFactors function in RStudio.However when I run library(nFactors) it appears
the following error message:
Loading required package: lattice**
Error: package or namespace load failed for ‘nFactors’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):**
there is no package called ‘mnormt’**
Any idea how can I resolve this issue?
Many thanks in advance
Panos

Install the missing dependency

install.packages("mnormt")
2 Likes

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

There is no mnormt package! This is indicated in the last line and I checked it by myself.
Thanks

Actually It says that mnormt is not available for R3.6.3. version so i have no clue what i will do.I tried to use pkgbuild but unsuccessfully

I don't understand what you mean. What have you checked by yourself?

mnormt is an R package available at CRAN and it's a dependency for nFactors so you need to install it using the command I gave you in my previous post. Do you get any error message installing it?

It says here https://cran.r-project.org/web/packages/mnormt/index.html that the package requires R 4.0 or higher. So to install, you should upgrade from 3.6.3 to 4.0.2 (the most recent version).