No logro instalar Forecast

Error: package or namespace load failed for ‘forecast’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘ggplot2’
In addition: Warning message:
package ‘forecast’ was built under R version 3.5.3

Have you tried installing the missing dependency?

install.packages("ggplot2") 

Si el error es el mismo, entonces no has logrado instalar ggplot2 correctamente, ¿puedes mostrar el mensaje completo que obtienes cuando intentas instalar ggplot2?

Nota: Por favor intenta hacer tus preguntas en inglés, ya que es el idioma preferido aquí y al usar español estás excluyendo a la mayoría de la conversación, reduciendo así tus posibilidades de obtener ayuda.

Perfect.

Shortly I share the installation message.

Message:

> install.packages("ggplot2")
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

https://cran.rstudio.com/bin/windows/Rtools/
Installing package into ‘C:/Users/activo/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)

  There is a binary version available but the source version is later:
        binary source needs_compilation
ggplot2  3.3.0  3.3.3             FALSE

installing the source package ‘ggplot2’

trying URL 'https://cran.rstudio.com/src/contrib/ggplot2_3.3.3.tar.gz'
Content type 'application/x-gzip' length 3058840 bytes (2.9 MB)
downloaded 2.9 MB

* installing *source* package 'ggplot2' ...
** package 'ggplot2' successfully unpacked and MD5 sums checked
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) : 
  there is no package called 'magrittr'
ERROR: lazy loading failed for package 'ggplot2'
* removing 'C:/Users/activo/Documents/R/win-library/3.5/ggplot2'
In R CMD INSTALL
Warning in install.packages :
  installation of package ‘ggplot2’ had non-zero exit status

The downloaded source packages are in
	‘C:\Users\activo\AppData\Local\Temp\RtmpglI5JM\downloaded_packages’
> library(forecast)
Error: package or namespace load failed for ‘forecast’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 there is no package called ‘ggplot2’
In addition: Warning message:
package ‘forecast’ was built under R version 3.5.3

This means that ggplot2 hasn't been successfully installed, you are trying to install from source but you don't have the compiler (RTools) installed in your system.

You can download a RTools version suitable for your R version from here

But, I would recommend updating your R version as well since it is considerably old.

Realizando todos esos pasos ahora tengo este mensaje.

> install.packages("ggplot2")
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

https://cran.rstudio.com/bin/windows/Rtools/
Installing package into ‘C:/Users/activo/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)

You still haven't installed RTools nor updated R

Si lo instale, quizás este faltando un paso adicional.

Tienes que ser más especifico, de lo contrario no tengo información suficiente para ayudarte.
Que versión de RTools has instalado? Cual es el mensaje de error completo?

En breve te indico toda la información

Ya instale en mi ordenador, En Windows de 64 bits: rtools40-x86_64.exe (recomendado: incluye compiladores i386 y x64).

Ahora bien,

Después de la instalación se ha completado, es necesario realizar un paso más para poder compilar los paquetes R: hay que poner la ubicación de los RTools hacer que los servicios públicos ( bash , make , etc) en el PATH . La forma más sencilla de hacerlo es crear un archivo de texto .Renviron en la carpeta Documentos que contenga la siguiente línea: PATH="{RTOOLS40_HOME}\usr\bin;{PATH}"

He intentado hacerlo y aún persiste el error.

Por ello te comente si estoy obviando un paso mas.

Rtools40 es para ser usado con R >= 4.0.0, y según el mensaje de error que muestras, estas usando R 3.5, por eso te di un link para descargar una versión anterior de RTools

Con base en tus indicaciones, corregí las instalaciones aplicada ahora bien, ya instale el RTools que aplica a mi versión 3.5, y logre ejecutar la consulta.

Muchísimas gracias por toda su orientación.

Mil gracias!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

Si lo instale, y he echo de todo pero el error persiste.