No longer able to install a github library; crashes on app launch

Hi all,

I have a Shiny app that's worked for years (both locally and on shinyapps.io) which still works locally but which can no longer run on shinyapps. The problem appears to related to installing a package from Github.

The code for installing the package has not changed. Nor did the package (until I tried editing the Description file as a possible workaround):

devtools::install_github("chrisadolph/tileForShiny")

I see the following error in the log file. Any thoughts on possible solutions?

2022-02-05T17:24:08.086566+00:00 shinyapps[279067]: Downloading GitHub repo chrisadolph/tileForShiny@HEAD
2022-02-05T17:24:09.577354+00:00 shinyapps[279067]: * checking for file ‘/tmp/RtmpK6X7bi/remotes1c28bc4041/chrisadolph-tileForShiny-5ecde46/DESCRIPTION’ ... OK
2022-02-05T17:24:09.614468+00:00 shinyapps[279067]: * preparing ‘tile’:
2022-02-05T17:24:09.659515+00:00 shinyapps[279067]: * checking for LF line-endings in source and make files and shell scripts
2022-02-05T17:24:09.618013+00:00 shinyapps[279067]: * checking DESCRIPTION meta-information ... OK
2022-02-05T17:24:09.660580+00:00 shinyapps[279067]: * checking for empty or unneeded directories
2022-02-05T17:24:09.661680+00:00 shinyapps[279067]: * looking to see if a ‘data/datalist’ file should be added
2022-02-05T17:24:09.783231+00:00 shinyapps[279067]:
2022-02-05T17:24:09.663948+00:00 shinyapps[279067]: * building ‘tile_0.4.14.tar.gz’
2022-02-05T17:24:09.837890+00:00 shinyapps[279067]: Warning in i.p(...) :
2022-02-05T17:24:09.837891+00:00 shinyapps[279067]: 'lib = "/opt/R/4.1.2/lib/R/library"' is not writable
2022-02-05T17:24:09.847552+00:00 shinyapps[279067]: Warning: Error in : Failed to install 'tile' from GitHub:
2022-02-05T17:24:09.847553+00:00 shinyapps[279067]: unable to install packages
2022-02-05T17:24:09.852100+00:00 shinyapps[279067]: 72:
2022-02-05T17:24:09.852244+00:00 shinyapps[279067]: Error : Failed to install 'tile' from GitHub:
2022-02-05T17:24:09.852246+00:00 shinyapps[279067]: unable to install packages

Thanks!

Chris

Hi!

Mmm, 2 things I think might be going on here:

  • some issue with your pkg dependencies. Maybe you can try setting the version of your deps to that of when everything was working fine (if the version changed).
  • some issue with shinyapps...maybe regarding your plan? Maybe your pkg is too heavy and it's being killed when deployed.

Also, could you share more details about how and when you noticed that your app was not working on shinyapps.

HTH!

The package dependency question is the first thing I wondered about; they haven't changed, but I tried removing a "Suggests" line from the github package (these packages aren't loaded/used in the code).

I have another Shiny app that stopped working for this reason sometime in 2019 or early 2020. (These are both apps that I use intermittently, so heavy use for a few weeks every year or two.). I think whatever changed happened back then. But the change wasn't in the package "heft" or contents (or my shiny app). It seems to be something about the permission to write to a directory?

Thanks,

Although I wasn't able to resolve this problem (installing from Github), I did find a workaround.

Could you share this workaround for people who might stumble upon a similar issue in the future?

I installed the package locally. deployApp() then passed the installed package up to shinyapps.io. Obviously this won't work for everyone, especially if updated from Github are desired.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.