Not able to download a package

Does someone know how to solve this ?

Warning in system(cmd) 'make' not found
ERROR: compilation failed for package 'SDMTools'

  • removing 'D:/R/R-4.2.1/library/SDMTools'

It seems you are trying to compile a package from source but missing the required compilers in your system.

We need more information to give you specific advice, what operating system are you using? Can you show the complete console output you get when you try to install?

I tried after downloading Devtool and then Downloading GitHub repo statsbomb/SDMTools@HEAD

The code is followed

:heavy_check_mark: checking for file 'C:\Users...\AppData\Local\Temp\Rtmpw5Akur\remotes1f9c95174f0\statsbomb-SDMTools-5d22d7a/DESCRIPTION' ...
─ preparing 'SDMTools':
:heavy_check_mark: checking DESCRIPTION meta-information ...
─ cleaning src
─ checking for LF line-endings in source and make files and shell scripts
─ checking for empty or unneeded directories
─ building 'SDMTools_1.1-222.tar.gz'

  • installing source package 'SDMTools' ...
    ** using staged installation
    ** libs
    Warnung in system(cmd) 'make' not found
    ERROR: compilation failed for package 'SDMTools'
  • removing 'D:/R/R-4.2.1/library/SDMTools'
    Warning message:

Installation des Pakets ‘C:/Users/.../AppData/Local/Temp/Rtmpw5Akur/file1f9c30aa524e/SDMTools_1.1-222.tar.gz’ had Exit-Status not equal 0

I think you are missing RTools in your system

https://cran.r-project.org/bin/windows/Rtools/rtools42/rtools.html

should i just download it now ? Is there any additional steps which I have to take care of ?

Thank you so much for your help

I kinda download the thing you said but it keep showing the same result after I enter the code...

If you install it without changing the default options, then no. Just to be sure, restart your R session.

Oh thats why

Thank you so much

I may have another problem. The second file shows something like this

rror: Failed to install 'StatsBombR' from GitHub:
Git does not seem to be installed on your system

Thank you and sorry for disturbing you

Do you have Git installed?

https://git-scm.com/download/win

Yes I did download it, I could not find anything about the way to set it up. Is there anything I need to know about before I entering to set it up ?

Thanks

Not that I'm aware of. You are not giving us much information about your problem, when asking for help about package installation issues you have to as specific as possible.

Please share the specific command you are using to install the package and the complete console output (do not omit anything even if it looks irrelevant to you).

Also, since you are trying to install very old, un-maintained packages, you have to consider the possibility that they are not compatible with the latest R versions, and maybe you are going to need to downgrade your R version if you absolutely need to use them.