not able to install both psych and mnormt at the same vision

hello
I am a beginner and I'm facing a problem
I need the package psych, when I install in 3.6.0 version, it asked me to install mnormt package too. but mnormt does not available under 4.0.0 version
so I upgraded to version 4.0.2. but psych installed gave me this error in the new vision

Warning in install.packages :
package ‘psych’ is not available (for R version 4.0.2)

I got confused about what to do, any help would be appreciated

If you copy-and-pasted that output directly from R, then you have mispelled psych as pysch

1 Like

Hello Myko, thanks for replaying.
No it's not copy paste
there is a misspelling here but in R there is not

but psych is available for R version 4.0.2
a binary is available
https://cran.rstudio.com/bin/windows/contrib/4.0/psych_1.9.12.31.zip

I find renv very useful to download particular versions of packages.
if you do

install.packages("renv")

then you'll be able to do

renv::install("psych@1.9.12.31")

What repo are you using? If you aren't specifying it in theinstall.packages() command, then you can check the default with getOption("repos")

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.