Not able to install R commander (Rcmdr) in rstudio

I am not able to find R commander (Rcmdr) in Rstudio , i am using rstudio version 1.1.456 and R for windows version 3.4.4.
Attached the screenshot

Hi Mara ,
Thanks for your reply i have tried installing it from R GUI also .
I have attached the screenshot.

From the Rcmdr docs

Depends: R (≥ 3.5.0)

This means that you need your version of R to be 3.5 at a minimum.

This is a duplicate of this post where I believe the answer works

1 Like

Hi ,
Thanks for your reply i have tried it but it is not working.

OK. Is the error the same ? What does it say ?

i am getting this error

Warning in install.packages("Rcmdr", "2.5.0") :
'lib = "2.5.0"' is not writable
Error in install.packages("Rcmdr", "2.5.0") : unable to install packages

Bas function install.packages does not provide an easy way to install previous version. There is no argument to provide version number. You provided the version number as the lib argument here.

In the post I linked, the advice command is

remotes::install_version("Rcmdr", "2.5.0")

from remotes :package:. This is a wrapper around install.packages to install previous version.

when i try to run

remotes::install_version("Rcmdr", "2.5.0")

i am getting this error

Error in loadNamespace(name) : there is no package called ‘remotes’

i am novice to r sorry if ran the command wrong.

The error is rather explicit: You need to install the remotes :package:

R is powerful because of its :package: that improves some usage and brings some features.

You need to

  1. install.packages("remotes")
  2. remotes::install_version("Rcmdr", "2.5.0")

:: is a way to use a function inside a :package: without calling library() and loading all functions. Obviously, you can also call library("remotes") the use install_version

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.