odbc 'breaks' connections

Hi,

For work I have two windows machine (laptop at home, desktop station at work). At work, I can install odbc and via 'Connections' - 'New Connection' set up a connection.

However, with my laptop, whenever I install odbc and click on 'New Connection' I see 'Preparing Connections' and RStudio keeps hanging on this (so before I see the possible connection types, it already hangs). RStudio remains responsive, but after half an hour it is still preparing.

Now, when I remove odbc and clcik 'New Connection' I see simply the odbc option and the spark. When I click odbc, it asks to install odbc and after installing it hangs again.

The differences in Sys.getenv() are minimal and installed packages are minimal, both machines are Windows 10, etc. So, I'm wondering, how to debug this issue efficiently?

Hi @CorneeldH, welcome to Community , after installing odbc and before pressing on "New Connection", can you run the following two commands and let me know if either hang?

odbc::odbcListDrivers()
odbc::odbcListDataSources()

Hi @edgararuiz , thanks! I got an rcpp error and when running your commands and when I googled it, I got this link (r - Rcpp package doesn't include Rcpp_precious_remove - Stack Overflow). In short: install.packages('Rcpp') fixed it :slight_smile: After that, running the commands as well as making a connection (via new connection or via script, al worked).

1 Like