On RConnect enterprise version: Application depends on package `an_internal_package` but I've removed all references to the package

I have trouble publishing my app on the RConnect platform

It keeps erroring at "Application depends on package "some_internal_package" but it is not installed.

The issue is that "some_internal_package" is not a CRAN package it's simply an internal one used by the team. Since we had so much issue with get RConnect to use the package we've REMOVED all references to the package in the code (yes I did a global find and can no longer find the package being mentioned at all).

So why does it still try to look for this package? Is it cos of some cache setting? We've successfully deployed this app before is it using some cache setting somewhere?

I have searched this forum and most of the solution just involve installing the packages again.

I mam suing RStudio Connect v1.8.4.2-2 Build "v1.8.4.2"

It's possible that the internal package is still being detected in the development environment. A couple of things you might try:

  • generate a manifest with rsconnect::write_manifest() and see if the relevant package is listed in the dependencies
  • create an isolated environment for the application using renv. You can let renv detect which packages are used in your code or install them on your own and see if you can successfully deploy the application once you've gotten it to work locally.

I've used renv and tried to exclude that package.

This is what I see when I run the manifest function. Seems to be stuck the manifest seems to try to find package somehow

Could it be that it looks for the renv.lock file or the renv folder even though the renv is not activated.

My rsconnect is 0.8.16

It's working now after removing renv.lock and the renv folder and then deploy