package "doMC" doesn´t install at R 4.2

Hi, my R is at 4.2 and I´m trying to install the package "doMC" but at the moment when I call the library it doesn´t find it .

doMC is only compatible with Unix like operating system, not Windows. An alternative for Windows users is to use the snow package instead (it uses different syntax though)

Or better use the doSNOW package which is a lot easier to use compared to SNOW and more similar to use when compared to doMC.