Package FuzzyR in Version 3.5.3

Dear RStudio Community,

I inherited code of a predecessor, programmed on an older version of RStudio.
I am running this code on version 3.5.3. I encountered a problem with the Fuzzy-System that uses functions of the FuzzyR package such as 'newfis', 'addvar', 'addmf' etc.
In Version 3.5.3 I can't find the package FuzzR to run these functions.
Is there any successor package that allows me to run the Fuzzy chunk successfully without having to modify the code? If not, is there any other package providing me with similar functions?

Kind regards,

The FuzzyR package is still available on CRAN at

Can you please provide more detail about exactly what is going wrong? How are you installing FuzzyR? What is the error message you get?

Hi Andrie,

thanks for your quick response. I downloaded FuzzyR via CRAN.
However, RStudio gives me the following error message:

Error: Dies ist R 3.5.3, Paket ‘FuzzyR’ benötigt >= 3.6.0

Translation: This is R 3.5.3, Package 'FuzzyR' requires >=3.6.0

Is there any way to get FuzzyR running on 3.5.3 or does it require 3.6.0?

Thanks a lot,

You could try one of the archived versions:

Hi Martin,

thanks for your help. Unfortunately, the archived versions of FuzzyR trigger the same error message:
This is R 3.5.3, Package 'FuzzyR' requires >=3.6.0

What is the quickest way to solve this issue?

Are you sure you installed the old versions correctly? Based on the dates they precede R3.6, so that cannot be the dependency.

Hi martin,

I uninstalled the current FuzzyR and installed the archived 2017 package again. Now it works!

Thanks a lot for the support.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.