package installation in local

Hi all,

I am trying to install packages in my local. But getting below error. Can any one guide me here what is the correct way of doing it.

install.packages("~/Folder/App/plotly_4.9.2.1.tar.gz", repos = NULL, type = "source")
Installing package into ‘C:/Users/home/Folder/App/renv/library/R-4.0/x86_64-w64-mingw32’
(as ‘lib’ is unspecified)
Error in startsWith(contriburl, "file:") : non-character object(s)

Hi Vinay,

Try to install with the upper R Studio menu, should be more easy.

Go to Tools > Install packages... and then Install from:, select Package Archive File and browse the package archive.

Captura de pantalla 2021-06-09 a las 11.35.11

Hope it helps.

Greetings.

I tried in this way as well. But still showing same error

Well, I had similar problem. Everything was fine until one day, when suddenly I couldn't install anything, because of this error. Run RStudio as admin and try again. It helped me and for a long time it was the only way to install package at my PC. I wish it work also in your situation :confused:

1 Like