package relaimpo. not installing.

Good evening.
I am trying to download the package relaimpo but i am getting the following error. What should I do?

install.packages("C:/Users/pc/Desktop/Lesson 5 systems Immunology/survey_3.37.tar.gz", repos = NULL, type = "source")
Installing package into ‘C:/Users/pc/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
ERROR: dependency 'numDeriv' is not available for package 'survey'

  • removing 'C:/Users/pc/Documents/R/win-library/3.6/survey'
    Warning in install.packages :
    installation of package ‘C:/Users/pc/Desktop/LESSON~1/survey_3.37.tar.gz’ had non-zero exit status

sessionInfo()
R version 3.6.3 (2020-02-29)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 18363)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252
[2] LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] tools stats graphics grDevices utils datasets
[7] methods base

other attached packages:
[1] ShinySOM_0.1 mhca_0.2.9000 shinyDendro_0.2
[4] htmlwidgets_1.5.1 bsplus_0.1.1 shinyWidgets_0.5.1
[7] shinyFiles_0.7.5 shiny_1.4.0.2 tidyr_1.0.2
[10] scattermore_0.6 flowCore_1.50.0 EmbedSOM_2.1.1

loaded via a namespace (and not attached):
[1] tidyselect_1.0.0 purrr_0.3.3 lattice_0.20-38
[4] pcaPP_1.9-73 colorspace_1.4-1 vctrs_0.2.4
[7] htmltools_0.4.0 stats4_3.6.3 rlang_0.4.5
[10] later_1.0.0 pillar_1.4.3 glue_1.3.2
[13] BiocGenerics_0.30.0 matrixStats_0.56.0 lifecycle_0.2.0
[16] robustbase_0.93-6 stringr_1.4.0 munsell_0.5.0
[19] mvtnorm_1.1-0 Biobase_2.44.0 fastmap_1.0.1
[22] httpuv_1.5.2 parallel_3.6.3 DEoptimR_1.0-8
[25] Rcpp_1.0.4 xtable_1.8-4 corpcor_1.6.9
[28] BiocManager_1.30.10 promises_1.1.0 scales_1.1.0
[31] graph_1.62.0 jsonlite_1.6.1 mime_0.9
[34] fs_1.3.2 digest_0.6.25 stringi_1.4.6
[37] dplyr_0.8.5 grid_3.6.3 magrittr_1.5
[40] tibble_2.1.3 crayon_1.3.4 rrcov_1.5-2
[43] pkgconfig_2.0.3 MASS_7.3-51.5 lubridate_1.7.4
[46] assertthat_0.2.1 rstudioapi_0.11 R6_2.4.1
[49] compiler_3.6.3

I want to install package "relaimpo".
I am getting the following error.
ERROR: dependency 'numDeriv' is not available for package 'survey'

  • removing 'C:/Users/pc/Documents/R/win-library/3.6/survey'
    Warning in install.packages :
    installation of package ‘C:/Users/pc/Desktop/LESSON~1/survey_3.37.tar.gz’ had non-zero exit status

Try installing the missing dependency

install.packages("numDeriv")

Hey
Thank you so much.
It is done.
Thank you.
I also reinstalled BiocManager and then ```
if (!requireNamespace("BiocManager", quietly = TRUE))
install.packages("BiocManager")
BiocManager::install()
BiocManager::install('relaimpo')
Thank you once again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.