packages failing to load

Each time I try to load a package - specifically dplyr, readr, ggplot2 - I get the following message:

Error: package or namespace load failed for ‘dplyr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘pillar’ 1.4.7 is being loaded, but >= 1.5.1 is required
In addition: Warning message:
package ‘dplyr’ was built under R version 3.6.3

I run R version 3.6.1 I have updated and run updated.packages(ask = FALSE, checkBuilt = TRUE)
(and got 40 warnings !) and still get the same Error message
This all started because I thought I had installed dplyr but when calling 'group_by' the console message was that the group_by function was not recognised.
Feeling frustrated. What to do ?
Why can I not install packages ?

It looks like you need to upgrade the pillar parkage at the very least.


should do it.

Since you are using a very old R version the latest version of the pillar package is only available for you as source. Do you have the required compilers installed in your system? This depends on what operating system you are on.

Thank you both
Most useful was comment from 'andresrcs' - "...using a very old R version" ! (donated by Uni)
I had been confused by information that I was using the most up to date version when clearly I wasn't
So, have now installed version 4.2.1 and all's good
Thanks again

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.