Pandoc-related Rmarkdown error when knitting:

Dear RStudio Community,

I am quite new to the community, even though I'm no "stranger" to R so I will try to be as specific as needed and hope you can help me resolve my issue. I must also say I have tried to look for solutions on the community prior to posting and couldn't find it :frowning:

System specs: Rstudio Version 1.2.5033

Background & problem:

I want to work out a Rmarkdown project in order to knit in PDF afterwards (I have TinyTex installed). When I click on the knit button, the Rmarkdown consol starts running but I always get the following message, no matter what format I choose to knit into. The .Rmd file is on my desktop. I have all required packages installed on the following library:

.libPaths()
[1] "\\garcsm0010/HomedirS$/mouliniv/Documents/R/win-library/3.6"
[2] "C:/Program Files/R/R-3.6.2/library"

Rmarkdown script I am trying to knit:

---
title: "Untitled"
author: "Victor M."
date: "25/03/2020"
output: beamer_presentation
---

```{r setup, include=FALSE}
knitr::opts_chunk$set(echo = FALSE)
```

## R Markdown

This is an R Markdown presentation. Markdown is a simple formatting syntax for authoring HTML, PDF, and MS Word documents. For more details on using R Markdown see <http://rmarkdown.rstudio.com>.

When you click the **Knit** button a document will be generated that includes both content as well as the output of any embedded R code chunks within the document.

R console message:
processing file: test.Rmd
|....................... | 33%
ordinary text without R code

|............................................... | 67%
label: setup (with options)
List of 1
$ include: logi FALSE

|......................................................................| 100%
ordinary text without R code

output file: test.knit.md

"C:/Program Files/RStudio/bin/pandoc/pandoc" +RTS -K512m -RTS test.utf8.md --to beamer --from markdown+autolink_bare_uris+tex_math_single_backslash --output test.tex --highlight-style tango --pdf-engine pdflatex --self-contained
pandoc.exe: test.utf8.md: openBinaryFile: does not exist (No such file or directory)
Erreur : pandoc document conversion failed with error 1
Exécution arrêtée

Could you please help me solve this issue?

Thanks a lot

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. Just for future reference: this type of error message really not needed.

The key to the error message is

pandoc.exe: test.utf8.md: openBinaryFile: does not exist (No such file or directory)

which, means that either pandoc is not installed at all, or it isn't findable.

Same problem here after upgrading to RStudio 1.2.5033.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.