PEM_read_bio:no start line

shiny
shiny-server

#1

To enable SSL I have created a key file (.pem) & a certificate file (.crt) using the following commands. RStudio Server is using the same and is working fine. But Shiny doesn't like it. After going through blogs I tried editing the file and did all permutations, but no use.

openssl pkcs12 -in mykey.pfx -nocerts -nodes -out mykey.pem
openssl rsa -in mykey.pem -check -out mykey.rsa.pem

openssl pkcs12 -in mykey.pfx -clcerts -nokeys -out mykey.crt

I even tried with rsa. No luck.

Any help or sample would be of great help.

Thanks,
Ashok.


#2

I solved it myself following https://www.markbrilman.nl/2011/08/howto-convert-a-pfx-to-a-seperate-key-crt-file/#comment-3408

The idea is to create a PEM file from the encrypted key.

openssl pkcs12 -in mykey.pfx -nocerts -out mykey.encrypted.key -- Not needed
openssl rsa -in mykey.encrypted.key -out mykey.decrypted.key -- Not Needed
openssl rsa -in mykey.encrypted.key -outform PEM -out mykey.encrypted.pem -- -- This is needed 1st Parameter for SSL switch in shiny-server.conf
openssl pkcs12 -in mykey.pfx -clcerts -nokeys -out mykey.crt -- -- This is needed 2nd Parameter for SSL switch in shiny-server.conf