Permission Denied installing package "car"

Hi, I received this warning when I tried to install "car" package. I´m trying using install.package("car"), and also from the RStudio interfaz, but it didn´t work. Any idea? Thanks

Error in install.packages : no fue posible abrir el archivo 'D:/JCB/R/win-library/4.0/file4b101e521ec7/BH/include/boost/geometry/util/readme.txt': Permission denied

Hello @BaldocBog,

There a variety of reasons why this could be happening. Run Rstudio as administrator first and see if that changes things otherwise it might be that you don't have write rights on that location (interesting to see it is a D: drive and not your typical C: location).

Other possible fixes you can have a look at here:

Let me know if you win :slight_smile:

I don´t undestand what happened. "car" library was a really trouble. I used .libpath() and after that install.packages("car"), and at the third time it worked. So, I can´t explain exactly if it was the solution, but anyway it´s working well. Thank you! Another solution is to install the new library not from Rstudio, but from Rgui. It works really better.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.