pink background with red dots in a file name

When i source a .R file, i could not understand why the name changed to contain these red dots.
When i'm trying to source the .R file with it's name- R does not find it, however, when in use list.files() and copy the file name- after i paste it in R console- it suddenly have these weird dots.
See attached screen shot below to fully understand the situation.
Hope you can help with this,

I am guessing but I do not think R likes an uppercase R.

Rename the file to Functions.Teva.r

Worked like a charm

R is perfectly fine with upper case .R, so if that change fixed matters then something else must be the underlying issue, like including . in the file name on Windows.

I've only changed the script name from: "Functions.Teva.R" to "Functions.Teva.r"


I actually tried a getfile.r vs a getfile.R and @martin.R is correct. Both work in Ubuntu. It may have been some wierd windows thing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.