Polygons not getting plotted on leaflet map since update

shiny
leaflet
shinydashboard

#1

I have a shiny app that has a leaflet map in it with two different polygons. The leaflet map was working all good and fine until I updated my leaflet package to 2.0.1. Now when I run the app... the polygons aren't getting plotted and there are no errors being thrown at me. I have looked around and haven't found anything that fixes my problem. I would appreciate it if anyone can give me some guidance or point me in the right direction!

Working code before I updated leaflet:

library(shiny)
library(shinydashboard)
library(leaflet)
library(sf)
library(rmapshaper)
### Read in shapefiles  ###
NJ_Map_Road<-st_read(getwd(),layer="2014_NJ_Integrated_Report_AU")
Impaired_HUCS<-st_read(getwd(),layer = "Impaired_HUCS_Shapefile")
### Change projection to work with leaflet ###
map_df <- st_transform(NJ_Map_Road, crs="+init=epsg:4326")
map_impaired_df<-st_transform(Impaired_HUCS,crs="+init=epsg:4326")
###########################################################################################
### simplify shapefiles ###
map_df<-ms_simplify(map_df)
map_impaired_df<-ms_simplify(map_impaired_df)
###########################################################################################
### This drop Z and M dimensions
good_map_df<- st_zm(map_df, drop = T, what = "ZM")
good_imp_map_df<- st_zm(map_impaired_df, drop = T, what = "ZM")
#################################################################

ui<- dashboardPage(
  header = dashboardHeader(),
  sidebar = dashboardSidebar(),
  body = dashboardBody(
    box(width=12,leafletOutput("leaf"))))
### Server ###
server<- function(input,output,session){
  ### This creates interactive map ###
  output$leaf<- renderLeaflet({
    leaflet(options = leafletOptions(minZoom = 7))%>%
      addTiles()%>%
      addTiles(group = "OSM (default)") %>%
      addProviderTiles(providers$OpenStreetMap.BlackAndWhite, group = "Grey") %>%
      addProviderTiles(providers$Esri.WorldImagery, group = "Satellite") %>%
      setView(lng = -74.4 ,lat =40, zoom = 7)%>%
      addPolygons(data= good_map_df,color = "#636060",weight = 1,smoothFactor = 1,
                  opacity = 0.5, fillOpacity = 0.1,group = "HUCs",fillColor = "white",
                  highlightOptions = highlightOptions(color = "blue",
                                                      weight = 2,bringToFront = TRUE))%>%
      
      addPolygons(data = good_imp_map_df,color = "#F3161B",weight = 1,smoothFactor = 1,
                  opacity = 0.5, fillOpacity = 2,
                  group = "Impaired HUCs",
                  highlightOptions = highlightOptions(color = "blue",
                                                      weight = 2,bringToFront = TRUE),
                  label = ~ paste(HUC14TXT,AU_name),
                  layerId = ~ good_imp_map_df$AU_name)%>%
      addLayersControl(
        baseGroups = c("OSM (default)", "Grey", "Satellite"),
        overlayGroups = c("HUCs","Impaired HUCs"),
        options = layersControlOptions(collapsed = FALSE))%>%
      addLegend("bottomright",colors = c("#636060","#F3161B"),opacity = 2,
                labels = c("HUC14s","Impaired HUCs"))
  })
  ###########################################################################################  
  ### Allows user to have map zoomed in when impaired HUC is clicked ###
  observe({
    click <- input$leaf_shape_click
    if(is.null(click))
      return()
    else
      leafletProxy("leaf")%>%
      setView(lng = click$lng , lat = click$lat, zoom=10)
  })
  
}

shinyApp(ui,server)

#2

This was crossposted (and solved) on Stack Overflow:

I reply also here for completeness.

The problem seems related to the fact that ms_simplify() adds names to the geometry column:

polys_sf<-st_read(system.file("shape/nc.shp", package="sf") ) %>% 
  st_transform(crs="+init=epsg:4326") %>% 
  ms_simplify(.)

names(st_geometry(polys_sf))

  [1] "0"  "1"  "2"  "3"  "4"  "5"  "6"  "7"  "8"  "9"  "10" "11" "12" "13" "14" "15" "16" "17" "18" "19" "20" "21" "22" "23" "24" "25"
 [27] "26" "27" "28" "29" "30" "31" "32" "33" "34" "35" "36" "37" "38" "39" "40" "41" "42" "43" "44" "45" "46" "47" "48" "49" "50" "51"
 [53] "52" "53" "54" "55" "56" "57" "58" "59" "60" "61" "62" "63" "64" "65" "66" "67" "68" "69" "70" "71" "72" "73" "74" "75" "76" "77"
 [79] "78" "79" "80" "81" "82" "83" "84" "85" "86" "87" "88" "89" "90" "91" "92" "93" "94" "95" "96" "97" "98" "99"

as suggested in https://github.com/r-spatial/sf/issues/880#issuecomment-435304536, removing the names will solve the issue. Therefore, this works:

library(shiny)
library(shinydashboard)
library(leaflet)
library(sf)
library(rmapshaper)
### Read in shapefiles  ###
polys_sf<-st_read(system.file("shape/nc.shp", package="sf") ) %>% 
  st_transform(crs="+init=epsg:4326") %>% 
  ms_simplify(.)

names(st_geometry(polys_sf)) = NULL

ui<- dashboardPage(
  header = dashboardHeader(),
  sidebar = dashboardSidebar(),
  body = dashboardBody(
    box(width=12,leafletOutput("leaf"))))
### Server ###
server<- function(input,output,session){
  ### This creates interactive map ###
  output$leaf<- renderLeaflet({
    leaflet(options = leafletOptions(minZoom = 7))%>%
      addPolygons(data= polys_sf)
  })
}

shinyApp(ui,server)

, while if the names(st_geometry(polys_sf)) = NULL line is removed the polygons are not shown.

@KWANGER : please have a look at FAQ: Is it OK if I cross-post? regarding policies about cross-posting on this forum.


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.