Posit Package Manager - httpuv - 2023-04-17

I tried download the package httpuv from Posit Package Manager in a specific date and get the error.

The code i ran:
options(repos = 'https://packagemanager.posit.co/cran/2023-04-17')
utils::download.packages(pkgs = 'httpuv', destdir = '.')

trying URL '**REPO/**src/contrib/httpuv_1.6.9.tar.gz'
Error in download.file(url, destfile, method, mode = "wb", ...) :
cannot open URL '**REPO/**src/contrib/httpuv_1.6.9.tar.gz'
In addition: Warning message:
In download.file(url, destfile, method, mode = "wb", ...) :
cannot open URL '**REPO/**src/contrib/httpuv_1.6.9.tar.gz': HTTP status was '403 MediaTypeBlocked'
Warning in utils::download.packages(pkgs = "httpuv", destdir = ".") :
download of package ‘httpuv’ failed

** I used REPO in the error message because i'm a new user and can't post more then 2 linkks :sweat_smile:

My R sesison:

R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

[1] LC_COLLATE=Portuguese_Brazil.1252 LC_CTYPE=Portuguese_Brazil.1252
[3] LC_MONETARY=Portuguese_Brazil.1252 LC_NUMERIC=C
[5] LC_TIME=Portuguese_Brazil.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.0.3 tools_4.0.3

Is something i did wrong? Or this could be in the Posit Package Manager? I succeded in downloading another 120 packages , but httpuv never works, i did even tried 5 times....

Thamks for the help.

Hi @lgschuck !

Thanks for your report. We did some testing and couldn't reproduce the problem on our end. The 403 MediaTypeBlocked error could be coming from some proxy or virus scanner/firewall incorrectly detecting the download as potentially harmful. Is it possible you access the internet through a corporate proxy server, or is there any virus scanner you can disable temporarily to confirm?


Thanks for the help. In my company doens't work and i don't have the permitions to disable firewalls and antivirus softwares. But in another computer (at home) it worked perfectly.

I thought that could be some other thing because from cran, at work, i downloaded the file with no problems.

Anyway thanks a lot for the attention. Sorry for the question, shoud have checked before post...