Preview 1.2.747 doesn't install in Ubuntu 16.04

rstudio

#1

When I try to install 1.2.747 in Ubuntu 16.04 I get this:

The following packages have unmet dependencies:
libclang-dev : Depends: libclang-3.8-dev (>= 3.8~) but it is not going to be installed

libclang-3.8-dev in turn requires other packages that won't be installed. I haven't spent time trying to figure this out but wanted to report the issue. Thanks!


#2

We'll take a look. Thanks for reporting!


#3

What happens when you try to explicitly install libclang-dev? That is, what is the output of:

sudo apt install libclang-dev

#4

@kevinushey, it worked this time! I tried it the first time and got an error about something else not being installable. But this time it just worked. Either I erred or the attempt to install did something.

Anyway, sorry for the false alarm!

Bob


#5

No worries! Thank you for taking the time to test-drive the preview release and let us know if you bump into any other issues.


#6

I just tried to install on a different machine and ran into the same problem. this has me wondering what fixed it before. Here's the output:

  1. libclang-dev doesn't install
sudo apt install libclang-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libclang-dev : Depends: libclang-3.8-dev (>= 3.8~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
  1. liblcang-3.8-dev doesn't install
sudo apt install libclang-3.8-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libclang-3.8-dev : Depends: libobjc-5-dev but it is not going to be installed
                    Depends: libclang1-3.8 (= 1:3.8-2ubuntu4) but it is not going to be installed
                    Depends: libclang-common-3.8-dev (= 1:3.8-2ubuntu4) but it is not going to be installed
 rstudio : Depends: libclang-dev but it is not going to be installed
           Recommends: r-base (>= 2.11.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The fix: install all at once:

sudo apt install libclang-dev libclang-3.8-dev libclang-common-3.8-dev libclang1-3.8 libobjc-5-dev libobjc4

I'm 98% sure I didn't previously issue the above command on the first machine where I had this problem. At any rate it worked here.


#7

I tried the install-all-at once in Ubuntu 18.04 but get these errors:

sudo apt-get install libclang-dev libclang-3.8-dev libclang-common-3.8-dev libclang1-3.8 libobjc-5-dev libobjc4
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libclang-3.8-dev
E: Couldn't find any package by glob 'libclang-3.8-dev'
E: Couldn't find any package by regex 'libclang-3.8-dev'
E: Unable to locate package libclang-common-3.8-dev
E: Couldn't find any package by glob 'libclang-common-3.8-dev'
E: Couldn't find any package by regex 'libclang-common-3.8-dev'
E: Unable to locate package libclang1-3.8
E: Couldn't find any package by glob 'libclang1-3.8'
E: Couldn't find any package by regex 'libclang1-3.8'


#8

Note that Ubuntu 18.04 does not provide libclang-3.8-dev (it probably supplies something newer, e.g. libclang-6.0-dev). But just installing libclang-dev should provide you with the 'default' version of libclang for the associated platform.


#9

That worked. Thanks very much.