Problem installing a package


#1

A student couldn’t install the digest package – the error message pointed to this file not existing:

http://cran.rstudio.com/bin/macosx/el-capitan/contrib/3.4/digest_0.6.15.tgz

My questions are:

  1. Where do I report this?

  2. What is the proper protocol for installing a package when install.packages() doesn’t work?

a) Try a different mirror:

`install.packages("digest", repo = "https://cran.revolutionanalytics.com/")`

If so, are there go-to mirrors that are known to be more stable?

b) Download the tar.gz and install as such:

`install.packages("~/Downloads/digest_0.6.14.tgz", repos = NULL, type="source")`

from: https://stackoverflow.com/questions/1474081/how-do-i-install-an-r-package-from-source

c) Use R CMD INSTALL in the terminal? (Does this require additional downloads? I have so much stuff installed that I don’t know what works for students and what doesn’t.)

d) Something else?

Thanks!


#2

I think digest is one of the packages which has just been updated but the compiled version is not yet available on the RStudio CRAN mirror. This can take about a day or two.


#3

I’ve had the same problem as well. So do you suggest me to just wait for a few more days?
I attached the error message I received.