Problem installing package "igraph"

Hello,
I can't install the igraph package. I've already tried a lot of things but it is still not working...
I am using Windows 10, R Studio 1.2.5033 and R 3.6.3
Here is the error message :

make: *** [C:/PROGRA~1/R/R-36~1.3/etc/i386/Makeconf:208: feedback_arc_set.o] Error 1
ERROR: compilation failed for package 'igraph'

  • removing 'C:/Users/Namow/Documents/R/win-library/3.6/igraph'
    Warning in install.packages :
    installation of package ‘igraph’ had non-zero exit status

I have seen exactly the same problems. Waiting for authors to correct it somehow. Something is wrong with compilation from sources as previous version installs without any issues.

Hi Andrzej thanks for your answer.
I ve' found this answer here : https://github.com/igraph/rigraph/issues/321
Maybe you can help and tell me what to do step by step ? Sorry I am a beginner...

Welcome @namow and @Andrzej.

An alternative is to install the binary version of the package (if they are available for your OS). In your case, you can try the following in the console:

install.packages("igraph", type = "binary")

Using type = "binary" may give you a slightly older version of the package, but most of the time, that should not cause too many problems.

Hi clausp !

Thank you for your answer ! It worked for me I had this :

install.packages("igraph", type = "binary")
Installing package into ‘C:/Users/Namow/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)

There is a binary version available (and will be installed)
but the source version is later:
binary source
igraph 1.2.4.2 1.2.5

essai de l'URL 'https://cran.rstudio.com/bin/windows/contrib/3.6/igraph_1.2.4.2.zip'
Content type 'application/zip' length 9157807 bytes (8.7 MB)
downloaded 8.7 MB

package ‘igraph’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
C:\Users\Namow\AppData\Local\Temp\RtmpM3mBza\downloaded_packages

But I needed the igraph package to install cytofkit2 with this command :

> devtools::install_github("JinmiaoChenLab/cytofkit2")

Unfortunately I have still the problem with igraph :

Erreur : Failed to install 'cytofkit2' from GitHub:**
Failed to install 'FlowSOM' from Bioc:**
(converti depuis l'avis) installation of package ‘igraph’ had non-zero exit status

I just had a quick peek at the Github page and that does not look like the suggested way to install the cytofkit2 package. What happens if you follow this part?

## try http:// if https:// URLs are not supported
source("https://bioconductor.org/biocLite.R")
biocLite("cytofkit")

Here is what's happened

> source("https://bioconductor.org/biocLite.R")
Erreur : With R version 3.5 or greater, install Bioconductor packages using BiocManager; see https://bioconductor.org/install
> biocLite("cytofkit")
Error in biocLite("cytofkit") : 
  impossible de trouver la fonction "biocLite"

I have tried something else (idea from this link https://github.com/JinmiaoChenLab/cytofkit/issues/53)

BiocManager::install("JinmiaoChenLab/cytofkit")

But again it did not work and I had this message

Erreur : Failed to install 'cytofkit' from GitHub:
  (converti depuis l'avis) installation of package ‘igraph’ had non-zero exit status

Hi @namow,
Do you really need the newest version of igraph package ?
The newest version is 1.2.5, the previous version is 1.2.4.2.
Installing 1.2.4.2 causes no problems.
So with:

install.packages("igraph")

when you see this;
obraz

click "No", and you are good to go.
This works for me on Windows 10 x64, R 3.6.2, RStudio v. 1.4.84.
Please let us know the result ?
Best regards.

PS. If you want to see my struggle with installation of packages, read this post:
https://community.rstudio.com/t/i-cant-install-dplyr-dev-version-and-rlang-dev-version-on-windows-10/48080