Problem installing packages HELPPP

I've come across this issue regarding "error in install.packages". This is what I get from Rstudio when I was trying to install packages:
package ‘downloader’ successfully unpacked and MD5 sums checked
Error in install.packages : ERROR: failed to lock directory ‘C:\Users\User\Documents\R\win-library\3.6’ for modifying
Try removing ‘C:\Users\User\Documents\R\win-library\3.6/00LOCK’

Steps taken so far -

System Information:

  • RStudio Edition: (Desktop or Server): Desktop
  • RStudio Version: Version 1.2.5033
  • OS Version: Windows 7
  • R Version: R i386 3.6.2

From Troubleshooting Guide: Using RStudio

Have you tried going to the folder C:\Users\User\Documents\R\win-library\3.6 and removing the file whose name starts with 00LOCK? To see this file, you may have to make hidden items visible, which I believe is an option under the View menu of the folder.

1 Like

Yes! I have tried removing the folder and it works back to normal. I really appreciate your kindness, thank you!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.