Problem installing Rcmdr (loading car pkg) on Mac Sierra

HI there!
I have been reading all previous topics about issues installing Rcmdr in R while on McSierra.
I have a similar issue as already been posted in this topic below, but with some differences and I would need your help to figuring what is the problem with my process.

I need to install Rcmdr in Mc, so I followed all the recommendations posted in the already known link (Installing X11, Xquarzt, restarting R, installing packages with all dependencies, installing all the packages R said were missing... I did all of it from R as well as from R studio.
Nonetheless,,, after many failures, I'm still getting this:

Installing package into ‘/Users/paulit/Library/R/3.5/library’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/octet-stream' length 5014770 bytes (4.8 MB)
downloaded 4.8 MB

The downloaded binary packages are in

Loading required package: splines
Loading required package: RcmdrMisc
Loading required package: car
Loading required package: carData
Error: package or namespace load failed for ‘car’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘zip’
Error: package ‘car’ could not be loaded

If anyone would be so kind to help me figure out what Im not doing? (After this, I also reinstall X11 and rerun it before installing Rcmdr a couple of times..
I did notice that whenever I needed to install and load car, car, RcmdrMisc, splines -before Rcdmr-,I receive a msg from R "error package not available on this R version".

I hope it's not a foolish question, as I ran out of ideas!
Many thanks!!!

Have you tried installing the zip package?


Haha... So.. I feel like a fool
I actually run the "install.packages("zip")" previously...without success...
Now, I gave it a shot again, as you said....
And it's finally running.
Thank you, the answer was all over it and I wasn't able to give it another shot!! :slight_smile:
Thanks, andresrcs !!!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.