Problem installing tidyverse - non zero exit status?

Hello all. I recently started using R again and as I am trying to install packages like tidyverse, I keep running into errors saying that dependencies like "vctrs" and other factors have non zero exit statuses. I'm not sure what this means or how to fix it. I've tried reinstalling RStudio and updating the packages I have but it's giving me the same errors. I'm attaching a screenshot of the code and I would greatly appreciate any help or advice as to how to go about fixing this.

You are not showing the complete console output so I can't know if we are seen the actual root cause of your problem but from what I can see you are missing Xcode in your system (not in R) and the recommended development tools for macOS systems.

These tools are required to compile packages from source and since you are using a very old R version, you are forced to install packages this way.

Note: Please do not post screenshots, it is considered a bad practice here, post formatted code instead, here is how to do it

Thanks for getting back to me so quickly and for the advice. I had to install the Command Line tools package to my Mac, so you were correct about missing Xcode and the problem not being in R. I think this fixed the problem as now I do not receive the error codes and the packages have been installed correctly into R.

BTW: Thanks for the advice, I'm new so I'll make sure to format my code in the future if I run into anymore issues. Thanks once again!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.