Problem installing zoo package

Hi! I'm taking The Analytics Edge course (certified) on EdX. It's my first time using R and I ran into some trouble with the second assignment. I am currently using R 3.2.0 GUI 1.65 Mavericks build as this is the version we were asked to download.

I'm trying to install the zoo package and i've done the ff:

'''install.packages('zoo_1.8-8.tgz', repos = NULL, type="source")
Installing package into '/Users/mlv/Library/R/3.2/library'
(as 'lib' is unspecified)
During startup - Warning messages:
1: Setting LC_CTYPE failed, using "C"
2: Setting LC_TIME failed, using "C"
3: Setting LC_MESSAGES failed, using "C"
4: Setting LC_MONETARY failed, using "C"
Warning in strptime(xx, f <- "%Y-%m-%d %H:%M:%OS", tz = tz) :
unknown timezone 'zone/tz/2020a.1.0/zoneinfo/Asia/Manila'

  • installing binary package 'zoo' ...
  • DONE (zoo)'''

3. install.packages('zoo',repos='')

When I answered Y, the installer ran but I got the error "Can't install the software because it is not currently available from the Software Update Server"

Any help would be much appreciated :smiley:

You have already installed zoo with your first attempt, Can you clarify what your problem is? Are you able to load the package library(zoo)?

This isn't the question you're asking, but you're running a version of R that is quite old, and, based on the error message, it sounds like you're working with someone or some data that is using a newer version (i.e. >= 3.5.0), so you're getting that error on load. See this answer for details:

Thank you @mara :slight_smile:

Hi @andresrcs,
Unfortunately no, i'm unable to.

Error in readRDS(pfile) :
cannot read workspace version 3 written by R 4.0.2; need R 3.5.0 or newer

What is strange that my classmates in the course were able to install Zoo with the same version of R.

This error is definitely related to your version of R. I understand you were asked to download a specific version, but I can't think of a reason that a more recent one would cause a problem for you.

Thanks Mara. I'm beginning to think that I should just update my version of R as well. A friend shared though that updating to R4.0 might be tricky since it's a major release. I might just go for 3.5. What do you think?

Jumping to everything above 3.5 is going to be equally tricky because that was an inflection point, so I would recommend going for the latest R version.

1 Like

Yeah, as @andresrcs said, 3.5 is (in some ways) more major than 4.0—that said, I think you should still go for it.

For example, in the tidyverse:

our general policy is to support the current version , the devel version , and four previous versions of R.

When that was written (2019), I believe that brought us to 3.2.3. Because 3.5 has been out for quite some time now, I think you'll run into more trouble not having an updated version than you will working with the one you have now.

@mara i installed v4 and was able to install the package! thank you so much for your help. :smiley: appreciate it a lot

@andresrcs thanks too!!!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.