Problem loading the arrow package: unable to load shared object

I am having trouble loading arrow package. After installing packages using:

install.packages('arrow') ,

No problem thus far... but then I try to load the arrow package, I get the following:

Error: package or namespace load failed for 'arrow' in inDL(x, as.logical(local), as.logical(now), ...):
unable to load shared object 'C:/Users/16111/AppData/Local/R/win-library/4.2/00LOCK-arrow/00new/arrow/libs/x64/arrow.dll':

Then i tried to use the following method to solve the problem:

install.packages('arrow', type = "source")

Then i get the following result,

I have tried installing and uninstalling R and R studio, with no effect. And I have tried to copy the arrow package form other computer, with no effect. Thanks so much for your help.

Hi @Tiger2,
Welcome to the RStudio Community Forum.

Try deleting the 00LOCK directory manually. See this link for some background info:
https://rdrr.io/cran/pacman/man/p_unlock.html
You won't be able to use the pacman package solution (unless it's already installed) as further attempted installs will probably also fail until the arrow-related issue is fixed!

Thank you very much. I'll try to do it.