Problem using usethis package for package development

I am trying to use usethis package to aid the development of package I am working on. I have created and started work on this package mainly using devtools. But whenever I try to use any function in the usethis package, e.g use_package() or use_github for instance, I always get this same error:

Error in if (any(mismatch <- res != res2)) { :
missing value where TRUE/FALSE needed

I have no idea what to do about this error. I've checked online but couldn't find much help. Any suggestions?

Can you give the traceback from your error? You can get this by running traceback() after the error occurs.

1 Like

The code referenced in the error message is coming from the desc package. I would look at your DESCRIPTION file and see if it is malformed in some way. If nothing is obvious posting the contents of the DESCRIPTION file here would help us find the error.


It worked! @jimhester. I had a look at my DESCRIPTION file and removed all the linespaces between entries I had manually added and boom, usethis now works. Thanks a lot. Thank you also @mara. Really appreciate your response.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.