Problem : Warning in install.packages : package is not available (for R version 3.6.1).

Hey, I'm a beginner with RStudio.

I'm conducting a Multiple Linear Regression. So I used a tuto in order to create a graph, on this website : https://rstudio-pubs-static.s3.amazonaws.com/284987_78ff71541a2c4026a3c9d346ef6130b8.html

I must use "ggPredict3d" and "ggPredict2d". So I'm following instructions and installing packages. But I can't. This message appears : Warning in install.packages :package ‘ggPredict3d’ is not available (for R version 3.6.1).

I'm looking for a solution in internet, but I don't find... Could you help me ?

Those are not packages, those are functions, and according to the tutorial they come from this package

devtools::install_github("cardiomoon/ggiraphExtra")

You are missing this system dependency, I'm not a MacOS user so I can't give you any advice on how to install it but hopefully somebody else will do.

Having problem with this as well! If anyone could assist in this would be great :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Yes I tried to install hit but it did not work.

devtools::install_github("cardiomoon/ggiraphExtra")
Error in loadNamespace(name) : there is no package called ‘devtools’

This is the clue, you need to install devtools (or alternatively remotes) package.

Those are normal installation messages, what is the problem with that?

Yes, I tried to do it...

But :

install.packages("devtools")
...
The downloaded source packages are in
‘/private/var/folders/zd/c6vlxkyx5qd8v4dg89n__4kh0000gn/T/Rtmp3CL43D/downloaded_packages’
Updating HTML index of packages in '.Library'
Making 'packages.html' ... done

I have installed devtools.

But the problem is with package ggiraphExtra.
I installed it. But when i ticked it in package there was this message :

Erreur : package or namespace load failed for ‘ggiraphExtra’ in dyn.load(file, DLLpath = DLLpath, ...):
impossible de charger l'objet partagé '/Library/Frameworks/R.framework/Versions/3.6/Resources/library/systemfonts/libs/systemfonts.so':
dlopen(/Library/Frameworks/R.framework/Versions/3.6/Resources/library/systemfonts/libs/systemfonts.so, 6): Library not loaded: /opt/X11/lib/libfreetype.6.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/3.6/Resources/library/systemfonts/libs/systemfonts.so
Reason: image not found