Problems installing the 'cati' package from the CRAN archive -

package-installation
#1

I am having problems installing an archived package called 'cati' (the live package has been deleted from the CRAN repository).

Is anybody able to tell me what I am doing wrong or whether using the archived package remains possible? Many thanks.

CRAN archive url: https://cran.r-project.org/src/contrib/Archive/cati/

=====

I have tried directly through Rstudio as well as with the following code:

library("devtools")
require(devtools)
install_version("cati", version = "0.99.2", repos = "http://cran.us.r-project.org")

I do not understand the error code I receive:

library("devtools")
require(devtools)
install_version("cati", version = "0.99.2", repos = "http://cran.us.r-project.org")
Downloading package from url: http://cran.us.r-project.org/src/contrib/Archive/cati/cati_0.99.2.tar.gz
These packages have more recent versions available.
Which would you like to update?

1: All 2: CRAN packages only
3: None 4: callr (3.1.1 -> 3.2.0 ) [CRAN]
5: cli (1.0.1 -> 1.1.0 ) [CRAN] 6: data.table (1.12.0 -> 1.12.2) [CRAN]
7: e1071 (1.7-0.1 -> 1.7-1 ) [CRAN] 8: ggplot2 (3.1.0 -> 3.1.1 ) [CRAN]
9: glue (1.3.0 -> 1.3.1 ) [CRAN] 10: gtable (0.2.0 -> 0.3.0 ) [CRAN]
11: highr (0.7 -> 0.8 ) [CRAN] 12: httpuv (1.4.5.1 -> 1.5.1 ) [CRAN]
13: knitr (1.21 -> 1.22 ) [CRAN] 14: lazyeval (0.2.1 -> 0.2.2 ) [CRAN]
15: mclust (5.4.2 -> 5.4.3 ) [CRAN] 16: processx (3.2.1 -> 3.3.0 ) [CRAN]
17: Rcpp (1.0.0 -> 1.0.1 ) [CRAN] 18: rlang (0.3.1 -> 0.3.4 ) [CRAN]
19: shiny (1.2.0 -> 1.3.0 ) [CRAN] 20: stringi (1.3.1 -> 1.4.3 ) [CRAN]
21: tibble (2.0.1 -> 2.1.1 ) [CRAN] 22: xfun (0.5 -> 0.6 ) [CRAN]
23: zoo (1.8-4 -> 1.8-5 ) [CRAN]

Enter one or more numbers separated by spaces, or an empty line to cancel
1: 3

  • installing source package ‘cati’ ...
    ** package ‘cati’ successfully unpacked and MD5 sums checked
    ** R
    ** data
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error in dyn.load(file, DLLpath = DLLpath, ...) :
    unable to load shared object '/Library/Frameworks/R.framework/Versions/3.5/Resources/library/rgl/libs/rgl.so':
    dlopen(/Library/Frameworks/R.framework/Versions/3.5/Resources/library/rgl/libs/rgl.so, 6): Library not loaded: /opt/X11/lib/libGLU.1.dylib
    Referenced from: /Library/Frameworks/R.framework/Versions/3.5/Resources/library/rgl/libs/rgl.so
    Reason: image not found
    Error : .onLoad failed in loadNamespace() for 'rgl', details:
    call: NULL
    error: Loading rgl's DLL failed.
    On MacOS, rgl depends on XQuartz, which you can download from xquartz.org.
    ERROR: lazy loading failed for package ‘cati’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/cati’
    Error in i.p(...) :
    (converted from warning) installation of package ‘/var/folders/bq/475n84d13xn9vrbx3v8fvdg40000gn/T//RtmpygprBg/remotes5a7b428accb3/cati’ had non-zero exit status
0 Likes

#2

It seems like you don't have xquartz installed in your system, lets start by installing that and see if that helps

https://www.xquartz.org/

0 Likes

#3

You were exactly right andresrcs. After installing xquartz, the package installed just fine.

Thanks so much for your help!

0 Likes

closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

0 Likes