Problems with tidyverse and jsonlite

When I try to install tidyverse, I get the issue "installation of package ‘jsonlite’ had non-zero exit status". I then tried to simply install jsonlite on its own, but I still get the issue that it has "non-zero exit status". Tried to update R-studio (I now have version 3.6.2) and the issue still occurs. Can anyone help?

If you scroll farther up in the console where the output from the installation is displayed, you should see the point where it actually failed. What does that message say?

After trying to install tidyverse, I am told it is also installing the dependency jsonlite, and I am asked "Do you want to install from sources the package which needs compilation?" When I say yes, I then get the error,
"xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘jsonlite’

  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/jsonlite’
    Warning in install.packages :
    installation of package ‘jsonlite’ had non-zero exit status

In that case, see a post from last year on a similar problem. You need to install x-code:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.