Professional Driver Application_Intent = ReadOnly

We have the following situation:

  • RHEL7
  • RStudio Workbench 1.4.1717-3, "Juliet Rose"
  • Professional Driver 1.8.0 (1.5.8.1000)
  • MS SQL Server 2016 Always On Cluster
    Server 1: Primary node
    Server 2: Secondary node readonly
    Server 3: Listener
  • Odbcinst.ini on RStudio Server
    [SQLServer]
    Driver = /opt/rstudio-drivers-1.8.0/sqlserver/bin/lib/libsqlserverodbc_sb64.so
    RStudio_Version = 1.8.0
    Version = 1.5.8.1000
    Installer = RStudio Pro Drivers
  • Odbc.ini:
    [READONLY_TEST]
    Driver = SQLServer
    Server = Listener
    Application_Intent = ReadOnly
    Database = Rstudio_readonly_test
    Port = 1433
    UID = xxxxx
    PWD = xxxxx

We have several sql databases that we can access with professional driver, no problem at all .

But now, we want connect directly to the readonly node by using the parameter “application_intent = readonly”, unfortunately that does not work.

Connect to the Listener/primary node (without application_intent): OK

Connect directly to the primary node: OK

Connect directly to the secondary node: OK

Primary and secondary DB can change the Server, that's why we need the parameter “application_intent”

RStudio Documentation:

Do you have any advice on how to solve this problem?

Thanks very much

Reto Iten

Which error message do you get when you use Application_Intent = ReadOnly in the DSN?

Testing in the linux console with isql: no error message is given. The cursor flashes until ctrl-C is pressed.

image

I have created a support ticket at RStudio. They didn't find any errors either and passed the problem on to the driver vendor.